The Treehouse Blog

Tag: r40

WPA working on my R40’s IPW2100… finally.

by on Mar.26, 2005, under Linux, Networking

I’ve spent maybe 10 hours on this now (not all this week, mind you, but still). Getting WPA-PSK w/ TKIP certainly isn’t as easy as it should be, but that is probably entirely due to driver issues. Seems you can’t buy a great 802.11g card for Linux.

I had tried various versions of the Linux IPW2100 drivers, 1.1.0 most recently, and always ended up getting errors saying that the IPW_IOCTL_WPA_SUPPLICANT ioctl was not available. This is a symptom of a driver that doesn’t have the WPA support, but lsmod clearly showed the TKIP and other encryption-related modules loaded. Google suggested using the load and unload scripts provided with the driver, and to check the initrd for an old driver that might be overriding the freshly-compiled one. modinfo confirmed that the new drivers were getting loaded… still no luck. That’s where I was for a long time, retrying every once in awhile to see if anything was happier.

As it turns out, there is a problem in the way the drivers are compiled as modules which can be fixed with this patch (local cache). Keep in mind that the post I’m referencing here is only two weeks old… so, I’m probably not the only one having this issue. I’m somewhat amazed (and very happy) that Google has indexed it that fast.

Now, technically, that was enough to fix my problems. However, I spent the next 45 minutes or so trying to figure out why my connection would reset several seconds after coming up… which turned out to be another instance of wpa_supplicant in the background screwing things up. Tip: run one wpa_supplicant at a time.

Comments Off on WPA working on my R40’s IPW2100… finally. :, , , more...

July 2019
S M T W T F S
« Mar    
 123456
78910111213
14151617181920
21222324252627
28293031  

Archives



Content Copyright © 2004 - 2018 Brady Alleman.
All Rights Reserved.